Results 1 to 5 of 5

Thread: 01 TC flickering headlights

  1. #1
    Senior Member
    Join Date
    Apr 2001
    Location
    Charlotte, NC & Clover, SC USA
    Posts
    616

    Default

    With lights on low beam, headlights flicker,go to high beam, they do not. Right headlight has new bulb and new connector, old connector was semi-fried. Multi=function switch does not have any terminals which have overheated.

    Any ideas for a fix?
    Bill Payne
    American Limousine, LLC
    Lake Wylie, SC
    704.576.5309
    Celebrating 9 years of superior service to the Charlotte, NC market. Serving corporate and individual clients with sedans, vans and limousines.

  2. #2
    Member Limo Padawan
    Join Date
    Dec 2006
    Location
    St.Cloud, MN
    Posts
    57

    Default

    Its your alternator.. rebuild it.. Go ahead and test it with a good multi meter, but it wont always catch it.. if you have dual alternators and dont want to rebuild both of them, the alternato in the mid top of the engine is the one that powers the car.

    Ciao
    Another Fool trying to make it in this business...
    http://www.profilelimousine.net

  3. #3

    Default

    Wimpy01- I had this exact same thing happen on a limo too. It turned out to be the headlight switch or knob on the dash. Something internal got hot at one time and just got dirty on the connectors.

    Have the actual headlight switch control in the dash checked.

  4. #4
    Member Limo Padawan
    Join Date
    Oct 2006
    Location
    Huntsville Alabama
    Posts
    57

    Default

    Wimpy, The first thing we need to know is what year the car is, the second thing is are the lights flickering at idle, at road speed, or at other times?

  5. #5
    Senior Member
    Join Date
    Nov 2006
    Posts
    1,903
    Blog Entries
    1

    Default

    Two possibilities:
    1 - A friend had this problem, he rebuilt the alternator and the problem stopped. The alternator was working but was weak. Once moving everything was fine.

    2 - Sometimes it's not the alternator, it's a weak battery. I replaced a battery in a limo once and fixed this problem.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •