Results 1 to 3 of 3

Thread: 1999 TownCar limo

  1. #1

    Default 1999 TownCar limo


    Hello Everyone i Just Bought a Limo for dirt cheap but needs its fair share of work any input on what could be wrong?
    -Tailights/License plate dont work but Brake lights work
    -The Rear of the limo sits low it doesnt rise up
    -Whole Back(passanger area) No Power to outlets ,Dome lights dont work,radio either or tv's no type of power.


    Ive checked all the fuses & switch in the back

  2. #2
    Senior Member MrQ45Limo's Avatar
    Join Date
    Feb 2009
    Location
    Milwaukee, Wisconsin
    Posts
    1,238
    Blog Entries
    4

    Default

    Look under the Dash by the Main Fuse Block (Stock Town Car Fuse Block) there should be a pig tail type wire with a inline fuse this is your main fuse for the rear power, if this is not your issue check the main power going to your Mastercon Located behind the drivers seat.
    Badger State Limousine Service
    "When nothing less than perfection will do"
    (414)-GO-GO-RED (414)-464-6733
    www. BADGERSTATELIMO.com

    http://www.Badgerstatelimo.com
    http://www.MILWAUKEEWISCONSINLIMO.com

  3. #3

    Default

    You should also check the condition of your auxiliary battery. If it's dead you won't get power to the rear. But all these problems you have should be an easy fix for a good mechanic.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •