Results 1 to 2 of 2

Thread: 2007 Tiffany LTC - Rear Heat won't shut off - all I get is heat, heat, and more heat.

Hybrid View

  1. #1
    Junior Member
    Join Date
    Apr 2016
    Location
    ChicagoLand
    Posts
    1

    Default 2007 Tiffany LTC - Rear Heat won't shut off - all I get is heat, heat, and more heat.

    Just had a new motor put in my 2007 LTC Tiffany 120 stretch. Now, all I get is heat in the back. Cycle the temp down and the blower slows but the heat doesn't let up.

    I am thinking that the mechanic somehow put the Heat Diverter Valve back in place with switched connections? Of the four hoses going into the diverter valve, three are always hot and one is NEVER hot...seems like that shouldn't be the case...

    The one hose that is not hot is at the end of the valve with the "arrow" - seems like he's got the return hose hooked where the engine hose should come into the system.

    Any thoughts or suggestions would be appreciated!

  2. #2
    Senior Member Billy Bob's Avatar
    Join Date
    Jan 2012
    Location
    Central Alabama
    Posts
    123
    Blog Entries
    1

    Default

    I would look under the hood first. Locate you vacuum line going to the heater line cutoff. It should be to the left center looking from the front of the car. Don't forget to remove you decorative plastic shield. You could have a vacuum leak, or the vacuum line became disconnected. This would give you Heat, Heat and More Heat.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •