Results 1 to 3 of 3

Thread: Tiffany 2007 Lincoln Town Car - Heat A/C reversed

  1. #1
    Junior Member
    Join Date
    Mar 2016
    Location
    Vancouver,B.C.
    Posts
    2

    Default Tiffany 2007 Lincoln Town Car - Heat A/C reversed

    Hello everyone, I have been a long time reader of this forum just recently signed up. There is a lot of great information here.

    I have a 2007 Lincoln Town Car that is giving me trouble. I purchased the limo used along with my company, so don't know the full history. I recently changed both alternators and the secondary battery due to the rear power always turning off. After doing so I noticed the temerature control is in reverse now. When the temp is put down the heat turns on, when the temp is set for heat the ac turns on.
    Just wondering if anyone has ever had this problem and/or a solution?

  2. #2
    Senior Member Billy Bob's Avatar
    Join Date
    Jan 2012
    Location
    Central Alabama
    Posts
    123
    Blog Entries
    1

    Default

    When you state that it is turning off, is it resetting by itself when the blower motors are running on high? Have you checked the 50 AMP Fuse connection under the hood. You may also need to feel the temperature of the power cable going into the computer behind the front seat. If it feels warm, this may be part of the problem.

  3. #3
    Junior Member
    Join Date
    Mar 2016
    Location
    Vancouver,B.C.
    Posts
    2

    Default

    I solved the ac/heat issue. I went to the shop that recharged the a/c he found some wires that the mechanic had on backwards. So that makes sense. it doesnt reset itself when the motors are on high, but when changing the temp the fan speed always resets to zero. Sorry guys im used to krystals, this is the first tiffany im playing with.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •