Results 1 to 9 of 9

Thread: 2008 lincoln towncar - krystal Koach wiring schemetics

Hybrid View

  1. #1

    Default 2008 lincoln towncar - krystal Koach wiring schemetics

    i have 8 passenger 2008 lincoln town-car. The rear lights, stereo and ac is not working. The solid isnt working either. Anyone else have this issue or have krystal enterprises wiring schematics?

  2. #2

    Default

    your fuse board behind the passanger seat up front needs to be checked. repaired or maybe replaced i think

  3. #3

    Default

    The first thing to do is to see if there is power going to the rear control panel. There probably isn't any. Should be easy to figure out.

  4. #4

    Default

    I have taken it to 4 different electricians and couple of mechanics. None of them can figure it out. And there not much help here in canada as w dont have mechanics or people that specialize in limousines. Krystal going out of business does not help.
    The last electrician told me that theres no power going to the command. and i might have to change the circuit board, which is again impossible to find. Any suggestion or idea will be highly appreciated.

  5. #5

  6. #6
    Junior Member
    Join Date
    Nov 2015
    Posts
    4

    Default

    Hard to sell if there is no power in the rear. There should be a big red wire going to the panel behind the front seats. Any electrician can check to see if it's hot. 12 volts. If it's not hot then there is a problem up front with your aux. alternator or aux. battery or something. If your aux. battery is dead you wont get power to the rear. If it is hot and there's no power in the back then it's a problem with the panel or solenoid. If there is an RV dealer near you they should be able to check because many RV's use a dual alternator and battery much like the system in most limos.

  7. #7

    Default

    I replaced the battery. I desparately need the wiring schemetics for 2008 krystal koach lincoln. Please let me know if anyone has one or knows sommeone that does.

  8. #8
    Senior Member
    Join Date
    Apr 2001
    Location
    Charlotte, NC & Clover, SC USA
    Posts
    616

    Default May be able to assist

    Email me @ junkmail0188atg.....com with your contact info.
    Bill Payne
    American Limousine, LLC
    Lake Wylie, SC
    704.576.5309
    Celebrating 9 years of superior service to the Charlotte, NC market. Serving corporate and individual clients with sedans, vans and limousines.

  9. #9
    Senior Member Cedar Mill Limousine's Avatar
    Join Date
    May 2008
    Location
    Crown Point, Indiana (Northern Indiana)
    Posts
    2,788

    Default

    Are you sure you replaced the right battery? There should be 2 batteries and 2 alternators to that car. The secondary battery is underneath the stock one. Access it by taking off front passenger tire and then the black plastic thing. Your power wire from that battery may be bad, so take out stock battery so you can get a good view of wires (sometimes the wires from the secondary battery gets pinched by stock battery. Just trace your power from secondary battery on back to see where the power stops.
    Rich Rottier
    219.808.0976 | richrottier@gmail.com

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •