Results 1 to 7 of 7

Thread: 2008 Tiffany Bus A/C Issues

  1. #1
    Super Moderator Limo Scene's Avatar
    Join Date
    Apr 2001
    Location
    Bakersfield, CA 93307
    Posts
    3,419

    Default 2008 Tiffany Bus A/C Issues

    I am at my wits end over an a/c problem that no one can fix. The front of the coach compartment a/c blows chilled air and the back blows HEATED air. I have turned off the heater hose valves underneath the bus so no hot water can back there. No one help me.
    looking for ideas..
    Jim A. Luff
    Forum Moderator
    Contributing Editor & Consultant - LCT Magazine

    Limousine Scene - An Award Winning Company Since 1990
    Bakersfield, CA
    Limousines, Sedans, Vans, Charter Buses, Limo-Buses, Wheelchair Vans www.limousinescene.com

  2. #2

    Default

    Sounds like a problem with the thermostat that controls the temperature of the rear unit.
    Dan Repass
    Celebrity & BOSS Limousine
    Lexington, KY
    859-255-LIMO
    www.255LIMO.COM

  3. #3

    Default

    Does this bus have dual ac compressors? If so, their rear system may need charged. I have a 2008 e450 limo bus that was formerly a shuttle bus before I converted it. It too has front and rear ac, but the front and rear have separate controls like a limo. I can turn it cold in the front and warmer in the rear or vice versa. On my bus there is a thermostat sensor that hangs down under the front dash that senses the coach temp. keeps the unit running at the desired temp. Not sure if Tiffany uses this same type of setup. If you do have separate controls, the problem could also be with the rear switch.
    There could also be a problem with the rear condenser fan. If it's not running at full speed, that could also cause the rear to not get cold.
    Dan Repass
    Celebrity & BOSS Limousine
    Lexington, KY
    859-255-LIMO
    www.255LIMO.COM

  4. #4
    Senior Member LIMOJESS's Avatar
    Join Date
    Jan 2006
    Location
    seattle, wa
    Posts
    1,521
    Blog Entries
    1

    Default

    The problem is your roof top a/c

    We had a similar problem to this too.

    We have a 2009 Tiffany E450 limo bus.

    The realys for the fans condensor were bad. The hard part was finding them and replacing them.
    The fans are located on the roof top.

  5. #5
    Member
    Join Date
    Nov 2008
    Location
    Seattle, Wa.
    Posts
    88

    Default

    Quote Originally Posted by Limo Scene View Post
    I am at my wits end over an a/c problem that no one can fix. The front of the coach compartment a/c blows chilled air and the back blows HEATED air. I have turned off the heater hose valves underneath the bus so no hot water can back there. No one help me.
    looking for ideas..
    More info would help, starting with a/c pressure readings. Are the low side (suction) hoses cold back to the expansion(s) valve or orifice tube(s)?

  6. #6
    Senior Member Billy Bob's Avatar
    Join Date
    Jan 2012
    Location
    Central Alabama
    Posts
    123
    Blog Entries
    1

    Default

    Yes, the question is? Do you have a dual compressor system. One problem we had after longer runs is that one compressor would start to ice over and the other would not cool at all. It was avery simple problem, the electrical connections (Connection on Compressors) were transposed. One sat on top of the other, I could see how they could just plug them in. After all they had a 50/50 chance of being right.

  7. #7
    Senior Member
    Join Date
    Nov 2013
    Location
    Yountville, CA
    Posts
    374

    Default

    Ok this is this blog at its finest!! Operators trying to help other operators!! I love this!!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •