Results 1 to 2 of 2

Thread: Electrical Question LTC

  1. #1
    Junior Member
    Join Date
    Nov 2013

    Default Electrical Question LTC

    Hi everyone,

    I figured this might be a good place to start trouble shooting. I'm running a 2005 LTC L series on my fleet and have been chasing 12v gremlins since the day I bought this car. Periodically systems will just shut down (windows, certain lights, dash functions, ect) forcing it out of service, but never for long because when I start pulling it apart, it'll start working again. I've pulled the dash out and the door panels to inspect the wiring and everything is tight and in place. Well, I think I figured it out, but I'd like to find some other people with more experience with these cars and see what they think.

    The other day, I shut the car off at the gas station and when I got back in 5 mins later, I turned the key, everything came right on, but when I hit the starter, everything died. No power at all. I popped the hood and messed with the cables and still nothing. However, when I put my hand on the fuse box in the engine compartment to open it, everything lit right up and worked as if it was new. So after this happened again today, the problem seems obvious. A bad connection at the box. I also noticed snow built up on the front of the fuse box. So seeing as how rain and snow are making it too the box, I'm wondering if anyone knows if corrosion is an issue on the INSIDE the fuse box, which may be the actual problem I've been chasing since day one. All the fuses and connections look clean on the top portion of it.

    Ps: Anyone that can provide factory wiring schematics for this car would be the coolest person ever. Dealerships here are no help when you ask them for material like that.

  2. #2
    Senior Member
    Join Date
    Jul 2013


    Since you are running a regular Town Car, I would take your question to this website that is much more active:

    The moderators will reply to posts with wiring schematics and other help. If you look through that site, many people have had those weird problems. The Town Car is full of these modules that control things like the lights, and often that's the culprit of intermittent problems.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts