Results 1 to 5 of 5

Thread: A/C Blowing hot in the rear need help ?

  1. #1

    Default A/C Blowing hot in the rear need help ?

    I have a 2004 Lincoln towncar 120" by Springfield and the A/C unit will work great some times front and back and then when i take it out the very next day it will blow warm air in the back and coolish air in the front

    Example: Cleaned the car in the morning was blowing cold air everything was good did a wedding in the afternoon it was not blowing cold coolish up front and warm in the back i tried adding some cans of freon while on the wedding and it did not help it still blew warm

    If anybody could let me know what you think the problem may be and what i should try first that would be greatly appreciated !!!

    Thank you very much !
    Last edited by LimoRich55; June 23rd, 2013 at 06:02 PM.

  2. #2
    Senior Member Billy Bob's Avatar
    Join Date
    Jan 2012
    Location
    Central Alabama
    Posts
    123
    Blog Entries
    1

    Default

    First, if you have overfilled your Freon, it will not cool. The same if there is not enough.

    Before you do anything else, remove the front cover and check for bugs and leaves between the radiator and the evaporator. Make sure there is enough airflow. Also, make sure if you have an external fan, as most limousines do, it is activated when the car is at idle.

    If you have high and low pressure gauges, make sure the needles and not jumping at low speed. Check for blockage, raise the engine speed to about 1,500 rpms and look at the High Pressure side. It should not go over 200 lbs. If the pressure rises above the threshold, the over limit switch will cut off the compressor.

    If everything looks good at this point, have a professional evacuate and recharge the system. This will run around $100.00.

    Does your dryer have an insulating jacket? Many mechanics will tell you it s not needed anymore. Demand a thermal jacket around the dryer, it will run around $20.00 for this and is well worth it.

    You could also have a defective Air Blend Door. You need to have the air reticulating within the vehicle.

    Hope this helps.

  3. #3

    Default

    Finally found out what it was ....The compressor/accumulator....evacuate the system and recharge ...now it blows ice cold air 1700.00 later !

  4. #4

  5. #5

    Default a.c. relays

    Did you check your relays on the board. Come on Man!!
    I. know you must have.
    good luck up there.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •