Results 1 to 6 of 6

Thread: My new website.

  1. #1

    Default My new website.

    I did my first one through yola, not knowing what you are doing made for a terrible website. I had theis one completed last week. Tell me what you think? www.tarponexecutivecarservice.com
    Last edited by TarponCars; September 28th, 2012 at 10:56 AM.

  2. #2
    Senior Member kslust's Avatar
    Join Date
    Jan 2009
    Location
    Kansas City, MO
    Posts
    223

    Default

    doesn't work!
    Very Respectfully,

    Karl S. Lust

    Regal Limousine & Transportation
    Kansas City, Missouri

    "If you've ever traveled this good,
    Welcome Back!"


    Kansas City Limo - Kansas City Airport Transportation

  3. #3
    Senior Member kslust's Avatar
    Join Date
    Jan 2009
    Location
    Kansas City, MO
    Posts
    223

    Default

    www.tarponexecutivecarservice.com go here! spelling error!
    Very Respectfully,

    Karl S. Lust

    Regal Limousine & Transportation
    Kansas City, Missouri

    "If you've ever traveled this good,
    Welcome Back!"


    Kansas City Limo - Kansas City Airport Transportation

  4. #4
    Senior Member Greg K's Avatar
    Join Date
    Apr 2002
    Location
    Upper Arlington, Ohio
    Posts
    578

    Default

    First glance as I run out to a meeting, will check deeper when I get back, there are a lot of visual elements that could stand to be adjusted, the most notable one would be the difference int he left and right columns, especially on this page: http://www.tarponexecutivecarservice.com/reviews/ At first I thought it was a case of it being coded to look right in IE and was just bad in FF, but I checked and it does the same in IE. Also really noticeable in IE is the red border around the top and left of the facebook icon (doesn't show in FF or Chrome)

    Overall there are some minor things that would clean this up a lot nicer, the main header image, slightly blurry, and the resizing of it came out bad, as most noticed in the lines along the TC's.

    I'm taking it that the black bars on either side of the towncar in the very top is part of your logo? The way it is presented, my first thought is they are placeholders for something that is missing, but then I noticed smaller ones on the logo at the bottom. That and the main title of the site, that image just comes out looking a bit rough.

    Again, minor things, but for someone like me, just stands out.

    A quick look at the code behind the site, you should add in a WP pluggin to handle SEO, currently you have no Meta Description tag. The site advertises at the bottom that you have SEO work on the site, however that and no <h1> tags just make it harder to get the right Google Love. The code doesn't validate, each page should be able to pass this checker: http://validator.w3.org/

    I don't see the normal tell-tale trace code to indicate you are using a Caching plugin for wordpress, those are highly recommended. (plus it is being nice to the other sites on the same hosting server you are using, WP while nice and customizable, for the most part is not the most efficient with data handling)

    Lastly, I would highly recommend getting Google Analytics on the site, if you are serious about what your site is doing for you, this is a must have for tracking the site use.

    Many things are on this list, but most all of them are pretty easy fixes (the cleaning up of graphics to blend better are the most difficult). Good start though.

    Well, I'm off to a meeting, I'll try to stop back at it and give a more thourough going over when I get back.

    -Greg
    This space intentionally left blank.

  5. #5

    Default

    Did you say you'll be more thourough later? Lol, wow!!!! I do very much appreciate the feedback, I'm sending your post to the guy who built my website cause I was lost after you said you were heading to a meeting. Thank you for your technical advice.

  6. #6
    Senior Member Greg K's Avatar
    Join Date
    Apr 2002
    Location
    Upper Arlington, Ohio
    Posts
    578

    Default

    Good morning. I had a little more time to take a second look now:

    On all of your pages, check the titles:
    Tarpon Executive Car ServiceHome &raquo; Tarpon Executive Car Service
    Tarpon Executive Car ServiceAbout Us &raquo; Tarpon Executive Car Service
    Tarpon Executive Car ServiceContact Us &raquo; Tarpon Executive Car Service
    Tarpon Executive Car ServicePhoto Gallery &raquo; Tarpon Executive Car Service
    Tarpon Executive Car ServiceReviews &raquo; Tarpon Executive Car Service
    Tarpon Executive Car ServiceReviews Archives &raquo; Tarpon Executive Car Service

    In your CSS, there is a reference to http://www.tarponexecutivecarservice...ages/img01.gif that doesn't exist

    In looking closer at the code, I see you are using an SEO plugin on the site, but again there is no META Description on your pages.

    On top of the right column not stretching out, the bottom of the right column doesn't have the rounded bottom on every page (ex, it is on http://www.tarponexecutivecarservice.com/reviews/ ) Also on closer look at the bottom of the left column, there is a color on the outside of the rounded corner.

    That covers most of what I would say on the techincal side. Definately more content, expecailly aiming for SEO targeting, would help. But in gerneal the items I mentioned are the key things. My other main gripes about the code, well it is a wordpress site, so the bloat will always be there ;-)

    Have a great day.

    -Greg
    This space intentionally left blank.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •