Page 1 of 2 12 LastLast
Results 1 to 15 of 17

Thread: Problem with rear air suspesion !

  1. #1
    Junior Member
    Join Date
    Nov 2008
    Location
    Standish Maine
    Posts
    28

    Default Problem with rear air suspesion !

    I have a 2004 Lincoln town car 120" limousine and this is my problem:

    left rear air bag went in October replaced both air bags

    All was well until 2-weeks a go when the left airbag broke again

    Replaced it and it broke again 2 days ago and is completely missing from the car ????????

    I cant hear the compressor going on now would this cause a repeat break in the airbag ??????

    Any help is greatly appreciated !!!!!!!!!!

    Thank you,

  2. #2
    Senior Member BLVD Limo's Avatar
    Join Date
    Sep 2008
    Location
    Kansas City Metro Area
    Posts
    2,590

    Default

    Are you buying the airbags designed for stretches?
    Tim Wiegman, Jr.
    Boulevard Limousine
    Travel Confidently!
    Serving Kansas City, Lawrence, Topeka
    http://www.BoulevardLimoKC.com - Kansas City Limos
    KC Airport Car Service

  3. #3
    Junior Member
    Join Date
    Nov 2008
    Location
    Standish Maine
    Posts
    28

    Default

    Yes there were two different kinds and i bought the one for limousines

    Is there supposed to be a brace on the left air bag that helps hold it together ?

  4. #4
    Senior Member
    Join Date
    Nov 2006
    Posts
    1,903
    Blog Entries
    1

    Default

    There is a clip on the top of each air bag, if these are not installed then they can leave the car. The clip holds the top of the air bag to the chassis so the air bag can not fall out if the air bag deflates enough to come loose. Sounds like you didn't install the clip properly. The clip is located in the top center of the bag, right next to the solinoid where the air-line connects.

  5. #5
    Junior Member
    Join Date
    Nov 2008
    Location
    Standish Maine
    Posts
    28

    Default

    The only thing left is the top half of the air bag the plastic with the valve is still there we bought a new clip and put it on right

    The clip is fine and it has only happened to the left side the right side is fine any other suggestions. ??????????

    Please Help !!!!!!
    Last edited by LimoRich55; May 7th, 2012 at 12:01 PM.

  6. #6
    Senior Member LIMOJESS's Avatar
    Join Date
    Jan 2006
    Location
    seattle, wa
    Posts
    1,429
    Blog Entries
    1

    Default

    I had a similar promblem on a 2005 limo and after the third time switched to springs and never had that problem

    Left side typically gets most of the load as the j seat in on the left side.

    There could be a bolt, metal clip or exhaust pipe which is located too close to the bag and causing it too leak.

  7. #7
    Senior Member Cedar Mill Limousine's Avatar
    Join Date
    May 2008
    Location
    Crown Point, Indiana (Northern Indiana)
    Posts
    2,691

    Default

    Quote Originally Posted by LimoRich55 View Post
    The only thing left is the top half of the air bag the plastic with the valve is still there we bought a new clip and put it on right

    The clip is fine and it has only happened to the left side the right side is fine any other suggestions. ??????????

    Please Help !!!!!!
    Quote Originally Posted by LIMOJESS View Post
    I had a similar promblem on a 2005 limo and after the third time switched to springs and never had that problem

    Left side typically gets most of the load as the j seat in on the left side.

    There could be a bolt, metal clip or exhaust pipe which is located too close to the bag and causing it too leak.
    That's wacky. Is the bottom base still attached?

  8. #8
    Junior Member
    Join Date
    Nov 2008
    Location
    Standish Maine
    Posts
    28

    Default

    Got new airbag in and i cant get the compressor to come on and cant get any air to go to the bags ?????????

    Help????????

  9. #9

    Default

    Check to see if power is getting to the compressor with a 12v tester. If not you may have a blown fuse somewhere.

  10. #10

    Default

    Has anyone thought a bad compressor could do this. Over pump, blow bags and now burn itself out. just a though

  11. #11
    Banned
    Join Date
    Sep 2011
    Location
    Ontario
    Posts
    126

    Default

    If there is a leak the compressor will be on a lot causing it to wearout faster.I do not think it can over pump an air bag.Usually how long do air bags last ?The right side of my Limo is 2 cm shorter than the left.I think the ride height sensors would need adjusting.Thanks

  12. #12

    Default

    Your compressor is either shot or not getting power. Should be easy to figure out. Height sensors don't adjust height side to side, only up or down according to load in the car.

  13. #13
    Senior Member Wade Randolph's Avatar
    Join Date
    Oct 2000
    Location
    Baton Rouge, LA USA
    Posts
    2,467

    Default

    You probably have a slow leak in that bag.

  14. #14
    Senior Member Wade Randolph's Avatar
    Join Date
    Oct 2000
    Location
    Baton Rouge, LA USA
    Posts
    2,467

    Default

    The pumps wear out fast when the bags are leaking. There is also a module that controls the pump and it is very expensive to replace. If you have leaking bags, a worn out pump and a bad module it is advisable to switch over to conventional springs and shocks.

  15. #15

    Cool those pesky bags

    Not to go against Wade and his experience. But I prefer air bags. I replaced a set of bags with coil springs and air shocks and was not happy with the adjusting ride height or the quality of the ride. After a few months I went back to the Lincoln Setup. New bags, solenoids and compressor, Thank God the module was fine. [/URL]www.arnottinc.com

    I now just let them do there thing.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •