Results 1 to 14 of 14

Thread: a/c fans not working in back of a 2003 120' royale

  1. #1
    Junior Member
    Join Date
    Aug 2011
    Location
    SHREWSBURY MA
    Posts
    3

    Default a/c fans not working in back of a 2003 120' royale

    Have a 03 royale with touch screen controls the fans for the 2 mannix units in back will not work from controls. Replaced board and still no go I have bypassed the touch control and put in a toggle switch for 1 of the units and fan works on high while giving it direct power from the board. New board new battery. the unit gets nice and cold just a fan power problem. Not sure whats left to try would be nice to have all touch controls working. I can live with the override will just add a 3 speed manual switch that i can control up front. Bought car new only 130.00 miles just use it for friends and family Any ideas would be helpful and thanks in advance Mike

  2. #2
    Senior Member
    Join Date
    May 2001
    Location
    Los Angeles, CA
    Posts
    1,688

    Default

    Sounds like a Blower Motor Resistor problem. Where that is in your limo and what kind. I have no Idea!!

  3. #3
    Junior Member
    Join Date
    Aug 2011
    Location
    SHREWSBURY MA
    Posts
    3

    Default

    Great thanks what am i looking for will check Sunday if i strike out will have tech check on it Monday, Thanks again

  4. #4
    Senior Member LIMOJESS's Avatar
    Join Date
    Jan 2006
    Location
    seattle, wa
    Posts
    1,453
    Blog Entries
    1

    Default

    Could be a Relay too.

  5. #5
    Junior Member
    Join Date
    Aug 2011
    Location
    SHREWSBURY MA
    Posts
    3

    Default

    So would i be right to assume that both the resistor and relay would be on the new board? If not any ideas where to look. Just can't seem to figure out why there is no power from board to unit but that it works fine when giving direct power. Thanks to any responders Mike

  6. #6
    Senior Member LIMOJESS's Avatar
    Join Date
    Jan 2006
    Location
    seattle, wa
    Posts
    1,453
    Blog Entries
    1

    Default

    Call up Royale and they should be able to give you a wiring diagram.

  7. #7
    Senior Member RoyalFleet's Avatar
    Join Date
    May 2010
    Location
    San Diego, CA
    Posts
    494

    Default

    My problem that started last night on a 2000 TC Ultra is my AC rear fans won't shut off, car off, rear power off. Everything is off but the fans. Any ideas?

  8. #8
    Senior Member LIMOJESS's Avatar
    Join Date
    Jan 2006
    Location
    seattle, wa
    Posts
    1,453
    Blog Entries
    1

    Default

    Looks like a bad relay. Happened to our limo bus last year.

  9. #9
    Senior Member
    Join Date
    Feb 2008
    Location
    Miami-Florida
    Posts
    270
    Blog Entries
    2

    Cool

    Quote Originally Posted by Steve W. View Post
    Sounds like a Blower Motor Resistor problem. Where that is in your limo and what kind. I have no Idea!!
    Sell the limo it is too old!

  10. #10
    Senior Member
    Join Date
    Apr 2008
    Location
    N.C. - Raleigh/Sanford/Pinehurst
    Posts
    491

    Default

    Quote Originally Posted by transporter View Post
    Sell the limo it is too old!
    too old for what?

    transporter, the best I remember, you have told a lot of people on here to sell their older vehicles. Just because you cannot run older vehicles in your area, does not mean that everyone else can't. There are some markets where nobody has newer vehicles. In my area, there are several companies with very nice 96-02 models, and I see them out all the time. Personally, the clientele we have requires newer model cars, but there are a lot of price shoppers who don't mind the older models.
    Jerry Thomas

  11. #11
    Senior Member RoyalFleet's Avatar
    Join Date
    May 2010
    Location
    San Diego, CA
    Posts
    494

    Default

    Quote Originally Posted by transporter View Post
    Sell the limo it is too old!
    It's easy to say that when your not the one forking out the money for newer cars. In this economy when everyone wants a pick up and drop and want it cheaper than a taxi would be newer cars don't make sense.

  12. #12
    Junior Member
    Join Date
    Mar 2012
    Location
    san diego,ca
    Posts
    1

    Default

    Yeah, I have an 1999 120" Tiffany that looks like new, I have never had a customer complain about the age of the car, unless your in the bussiness you would not even know the difference between the 99 and a 2011. How much is a new 120" tc. I know once you drive it off the lot it just droped $15000 in value.
    Last edited by jimmi j; April 13th, 2012 at 10:50 PM.

  13. #13
    Senior Member LIMOJESS's Avatar
    Join Date
    Jan 2006
    Location
    seattle, wa
    Posts
    1,453
    Blog Entries
    1

    Default

    A 2013 TOwn Car 120" limo is priced around 87500 to 89000 from royale.

    Hopefully price will drop down for the 2014 model.

    Not worth it.

    Jess

  14. #14
    Senior Member kslust's Avatar
    Join Date
    Jan 2009
    Location
    Kansas City, MO
    Posts
    218

    Default

    Quote Originally Posted by transporter View Post
    Sell the limo it is too old!
    I'm really starting to like this cat! I seriously think he just throws random sh!t out there to get us wound up! LOL! Nothing like a blood pumping. Anyways, yeah. No comment.
    Very Respectfully,

    Karl S. Lust

    Regal Limousine & Transportation
    Kansas City, Missouri

    "If you've ever traveled this good,
    Welcome Back!"


    Kansas City Limo - Kansas City Airport Transportation

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •